Artykuł

The shadow copy provider had an unexpected error while trying to process the specified command.

Recently we had a case where an offsite backup in Altaro VM Backup was supposed to be written to Western Digital external drive. Before that is done we usually encrypt drive with Veracrypt (replaced TrueCrypt). After the drive was connected and mounted backups started failing.

Problem Description

This is our standard setup for most of our Clients. While Altaro VM Backup offers AES encryption by itself (Unlimited edition only) we usually encrypt offsite drives with Veracrypt for double protection, so that when the drive is lost data stays safe. While at the time of writing we already know that external drive was the cause of our problem it wasn't that obvious in the beginning.

First signs started to show up something is wrong when the backup failed and we got Altaro to send us daily email with failed backups.

This message doesn't say much except that there's a problem with Windows Shadow Copy:

Altaro Hyper-V Backup cannot create a Windows Shadow Copy at this time. The backup will be retried in a few minutes, since this problem is sometimes caused by the system being too busy to complete a Shadow Copy or other temporary issues. However, if the error persists, please contact support@altaro.com so that we can identify what is required to configure this host correctly and avoid Shadow Copy problems. (4103)

Since it's not uncommon for backup to fail with VSS errors we went ahead and verified Altaro configuration and retried manual backup of Hyper-V machines. Unfortunately, it still failed.

At this point, it was clear we need to investigate VSS. First steps involved checking if VSS writers are in good condition.

Few timeouts confirm the problem with VSS. Another check involved verification of volumes on which VSS is expected to work.

This can also be verified by right clicking any drive in Explorer, going into Properties and under Shadow Copies there should be a nice table with all VSS-enabled drives. Unfortunately again it confirms there's a problem with VSS.

While rebooting machine used to fix such issues it's always worth to know where it comes from and what caused the problem, especially if it happens often.

Solution

So what was the problem? It seems the problem is related to VeraCrypt/Truecrypt way of mounting devices. If you encrypt the drive and mount it standard way VSS isn't able to provide shadow copy of that drive and blocks backup ability on Windows. After dismounting VeraCrypt volume vssadmin commands starts working fine.

Quick verification under Windows Explorer also confirmed that VeraCrypt is at fault.

And backups starts working again… but still, we needed to have VeraCrypt working. To get VeraCrypt working properly and not block VSS based backups one has to make sure that mounted external drives are treated as a removable medium.

This makes sure Shadow Copies work as designed and backups can be made properly, including offsite backups to external drives.

Tags: , , , , , ,

This is a unique website which will require a more modern browser to work! Please upgrade today!