Artykuł

Upgrading Exchange 2010 SP3 to Rollup Update 18 fails with blank webpage

Upgrading Exchange 2010 SP3 to Rollup Update 18 is fairly smooth process. This rollup update is part of standard Windows Update feature, you go in, press update, and if you're not careful enough (as you should be) your Exchange SP3 RU 18 is on it's way. In my case it first was stuck on all Exchange services being disabled which I've fixed with Qucik script fix for disabled services which was caused by Pulseway not being disabled prior to installation. But that's not what the post is about. After restarting installation of RU18 things went smoothly and finished installing Exchange update. Unfortunately OWA webpage was blank after upgrading.

Problem Description

After updating Exchange 2010 to SP3 Rollup 18 a post-check process requires to go and verify if everything went smoothly. Unfortunately after opening up OWA webpage it was completely blank with a weird &reason=0 added in the end.

Link: https://poczta.private.pl/owa/auth/logon.aspx?url=https://poczta.private.pl/owa/&reason=0

No error messages were present on the website.

That's a bit unexpected.

Solution

To fix this issue you must start updatecas.ps1 script in the Exchange Management Shell as Administrator. The script can be found at C:\Program Files\Microsoft\Exchange Server\V14\Bin and comes with update rollup. The script handles OWA and ECP updates.

Finally refresh of website gives a proper web app again. Phew…

It's a bit weird this script is not started as part of update, but fortunately it's readily available as part of installation.

Tags: , , , , , , , ,

This is a unique website which will require a more modern browser to work! Please upgrade today!